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VuGen cannot record with Chrome an https application which uses QUIC
Title :
VuGen cannot record with Chrome an https application which uses QUIC
Document ID :
KM01132718
Product - Version:
performance center ; loadrunner ;
OS :
Updated :
Mon Aug 25 09:46:31 GMT 2014
Summary :
Problems appear during recording of https page in VuGen 11.5x or 12.x with Chrome if the application uses QUIC. LoadRunner currently does not support QUIC and Internet Explorer or Firefox should be used to record the application.
Problem

VuGen 11.5x and 12.x are unable to record an https page with Chrome browser.

In the recording log the following error message can be found:

Analyze segments filter initialization ******
****** Error: found multiple wplus_http_wsock_request_ex events with the same processID, sessionid and httpid!

It is followed by "Alternate-Protocol: 443:quic" as shown in the sample below:
****** Response Header For Transaction With Id 316 ******
HTTP/1.1 304 Not Modified
X-Content-Type-Options: nosniff
X-Frame-Options: SAMEORIGIN
X-Xss-Protection: 1; mode=block
Date: Thu, 10 Jul 2014 14:15:39 GMT
Server: GFE/2.0
Alternate-Protocol: 443:quic

Cause

The error message is caused by QUIC because LoadRunner currently does not support it. 

Once Chrome browser sees Alternate-Protocol: 443:quic header, it switches to QUIC. This is the reason why Chrome cannot be used.

Fix

To overcome the problem during recording with VuGen use a browser which does not support QUIC such as Internet Explorer or Firefox.