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UOC - server does not load all alarms
Title :
UOC - server does not load all alarms
Document ID :
KM01495401
Product - Version:
temip product family ; oss unified console ;
OS :
Updated :
Wed Jan 25 10:31:12 GMT 2017
Summary :
Following an update in the configured OCs to be monitorized by UOC ( monitored_ocs = ["oc1", "oc_2", ... , "ioc_n"]) UOC starts loading the alarms, and then stalls.
Problem

Following an update in the configured OCs to be monitorized by UOC ( monitored_ocs = ["oc1", "oc_2", ... , "ioc_n"]) UOC starts loading the alarms, and then hangs.

Cause

From the UOC Operation context list view, customer is able to browse through all Operation Contexts.
All monitored OCs have well the TeMIP “Emit Aggregate Event” attribute set to true (This is the default for NOM)

In some circumstances/configurations the request timeout timer of NOM may expired too early. This timer duration could be extended by modifying the camel-context.xml file (cf below):

$ edit  $UOC_DATA/adapters/nom_temip/resources/camel-context.xml

Replace

<endpoint id="actionsToNom" uri="nomjms:topic:com.hp.openmediation.actions"/>

By

<endpoint id="actionsToNom" uri="nomjms:topic:com.hp.openmediation.actions?requestTimeout=30000"/>

Where 30000 means 30 seconds. The default value is 20000.

Then restart or start the UOC server.

$ uoc stop
$ uoc start

Fix

With the previous recommandation and customer could load successfully all the alarms in Real Time Alarm View (about 600k alarms).