Self-Solve Knowledge Search

Minimize Maximize
HPE Service Manager (SM) non-Process Designer (non-PD) workflow, CI Visualizatio...
Title :
HPE Service Manager (SM) non-Process Designer (non-PD) workflow, CI Visualization and telephony cannot work in Chrome (version 42 or later) and FireFox (version 26 or later) by default.
Document ID :
KM01585680
Product - Version:
service manager ;
OS :
Updated :
Tue May 23 10:02:14 GMT 2017
Summary :
SM non-PD workflow, CI Visualization and telephony are implemented with java applet technology that relies on NPAPI in browser to run. However, NPAPI support is disabled by default in Chrome (version 42 or later) and FireFox (version 26 or later) by default. Workaround to run these SM components is provided in this document.

Problem

HPE Service Manager (SM) non-Process Designer (non-PD) workflow, legacy CI Visualization and legacy telephony cannot work in Chrome (version 42 or later) and FireFox (version 26 or later) by default.

·        Non-PD workflows are displayed as follows.

non-PD workflow

 

·        CI Visualization diagram is displayed as follows.

CIVisualizationDiagram

 

·        For telephony, it simply stops working and new interaction cannot be opened via DDE anymore.

 

For these issues, you must follow the steps provided in the workaround section to resolve them.

However, these issues does not exist in IE, you can use these SM components in IE as usual.

Impact Scope

·       Chrome

SM 9.33 and later versions are impacted by this problem since SM started to support Chrome from version 9.33.

·       FireFox

All SM versions that support FireFox.

Cause

·       Chrome

SM non-PD workflow, legacy CI Visualization and legacy telephony are implemented with java applet technology that relies on NPAPI in browser to run. NPAPI support is disabled by default in Chrome in April 2015 (Chrome 42) and one override is provided to re-enable the NPAPI. However, from September 2015 (Chrome 45) both the override and NPAPI support is permanently removed from Chrome (See http://blog.chromium.org/2014/11/the-final-countdown-for-npapi.html  for reference).

If your Chrome is in a version from 42 to 44, you have to re-enable NPAPI via the override provided by Chrome to make SM non-PD workflow, legacy CI Visualization and legacy telephony work (See below workaround section for detail).

If your Chrome is upgraded to version 45 or later, SM non-PD workflow, legacy CI Visualization and legacy telephony will simply stop working due to the fact NPAPI is permanently removed from Chrome. So we recommend that you keep Chrome below version 45.

·       Firefox

Similarly, NPAPI support is disabled by default in FireFox (version 26 to 51) and is removed permanently removed from FireFox as of version 52. (See https://support.mozilla.org/en-US/kb/npapi-plugins )

If your Firefox is in a version from 26 to 51, allow the Java plug-in to launch (See below workaround section for detail).

If your Firefox is upgraded to version 52 or later, SM non-PD workflow, legacy CI Visualization and legacy telephony will simply stop working due to the fact NPAPI is permanently removed from Chrome. So we recommend that you keep Firefox below version 52 or use Firefox 52 ESR (32 bit).

Workaround

·       Chrome

You need to enable NPAPI manually and keep Chrome below version 45 to make SM non-PD workflow, CI Visualization, and telephony work correctly.

If you are using Chrome version 42 to 44, you can follow the steps below to enable NPAPI:

1.      In your URL bar, enter:

chrome://flags/#enable-npapi

2.      Click the Enable link for the Enable NPAPI configuration option.

3.      Click the Relaunch button that now appears at the bottom of the configuration page.

If you are Enterprise administrator of Chrome version 42 to 44, you can enable NPAPI java plugin by adding “java” to EnabledPlugins policy list.

 For Chrome version 45 or later, no workaround is available to enable NPAPI to make SM non-PD workflow, legacy CI Visualization and legacy telephony work. Therefore, the recommendations are as follows:

o   Keep your Chrome below version 45 (You can follow https://www.chromium.org/administrators/turning-off-auto-updates to turn off auto updates in Chrome.).

o   Use IE instead.

o   Migrate to PD workflow (introduced as of SM 9.40) and use the new CI Visualization and telephony solution (introduced as of SM 9.50).

 

·       FireFox

If your Firefox is in a version from 26 to 51, when Firefox prompts you

to allow the plug-in to launch when you use telephony (the legacy CTI

method) and workflows (non-Process Designer-based), click Allow to continue.

For Firefox version 52 or later, no workaround is available to enable NPAPI to make SM non-PD workflow and legacy telephony work.  Therefore, the recommendations are as follows:

o   Use IE instead.

o   Migrate to PD workflow (introduced as of SM 9.40) and use the new telephony solution (introduced as of SM 9.50).

o   Keep your Firefox below version 52 or use Firefox 52 ESR (32 bit only, which still supports NPAPI).

Note: If you use legacy CI visualization in Firefox, you cannot view the CI hierarchy. Therefore, if you need to use the  CI visualization feature,  the recommendations are as follows:

o   Use IE instead.

o   Migrate to the new CI Visualization (introduced as of SM 9.50).