Self-Solve Knowledge Search

Minimize Maximize
Error -205177: IPC connection to browser process is lost during replay of TruCl...
Title :
Error -205177: IPC connection to browser process is lost during replay of TruClient Firefox script
Document ID :
KM02044149
Product - Version:
performance center 12.20 ; loadrunner 12.02 12.50 ;
OS :
Updated :
Tue Jan 05 13:05:58 GMT 2016
Summary :
Using a "Close active browser window" step in TruClient Firefox leads to the "Error -205177: IPC connection to browser process is lost" during replay in load mode when the step is used to close the main browser window.
Problem

"Error -205177:  IPC connection to browser process is lost" is shown in the replay log of TruClient Firefox 12.20 or 12.50 when the script is replayed in load mode. 

The replay log looks as follows:

t=00006011ms: ** 2: Close active browser window ** started    [MsgId: MMSG-205180]
t=00006668ms: Error -205177:  IPC connection to browser process is lost    [MsgId: MERR-205177]
End auto log messages stack.

 

Cause

A "Close active browser window" step in TruClient Firefox produces the error message if the step is used to close the main browser window (the one containing TruClient sidebar).

This step should only be used for closing new windows that were opened during the business process as shown in the snapshot below.

Second Window

Fix

If the main window needs to be closed the correct approach is to:

  1. Open another tab,
  2. Perform all the actions\steps there and 
  3. Close that tab.

An example is shown in the snapshot below.

image text

Additional documents which may be of interest:

KM02044266 - How to use the step "Close active browser window" in TruClient FireFox, TruClient IE and TruClient Web Protocols